?uem/p1-90`グローバルオブジェクトは:
new 演算子を使用してこのプロパティは属性 { [[Writable]]:
このプロパティは属性 { [[Writable]]:
このプロパティは属性 { [[Writable]]:
このプロパティは属性 { [[Writable]]:
この関数は %eval% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
eval の呼出し元と eval 関数自身の両方の realm である。eval 関数の呼出しに対する呼出し元コンテキストのコードまたは eval コードのいずれかが let、const、または class 宣言によって導入される束縛は、常に新しい LexicalEnvironment 内にインスタンス化されます。
ホスト定義の抽象操作 HostEnsureCanCompileStrings。引数 calleeRealm (
paramStrings は、関数eval 呼出しに渡された文字列を表します。
direct は、評価が
HostEnsureCanCompileStrings の既定の実装は、
eval は、グローバルレキシカル宣言によって隠蔽されるグローバル var 宣言を作成しない。この関数は %isFinite% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
この関数は %isNaN% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
ECMAScript コードで値 X が X !== X という形式の式です。X が
この関数は、string 引数の内容を10進リテラルとして解釈した結果に従って
これは %parseFloat% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
この関数は string の先頭部分だけを
この関数は、指定された radix に従って string の内容を解釈した結果に基づく
これは %parseInt% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
Uniform Resource Identifier、すなわち URI は、インターネット上のリソース(Web ページやファイルなど)と、それらにアクセスするための転送プロトコル(HTTP や FTP など)を識別する String です。ECMAScript 言語自体は、この節で説明する URI をエンコードおよびデコードする関数を除いて、URI を使用するためのサポートを提供しません。encodeURI および decodeURI は完全な URI を扱うことを意図しています。これらは、予約文字が特殊な意味(区切り文字など)を持つことを意図しているものと仮定するため、それらをエンコードしません。encodeURIComponent および decodeURIComponent は URI の個々の構成要素を扱うことを意図しています。これらは、予約文字がテキストを表しているものと仮定し、その構成要素が完全な URI の一部となるときに特殊な意味を持たないようにエンコードしなければならないものとします。
予約文字の集合は RFC 2396 に基づいており、より新しい RFC 3986 によって導入された変更を反映していません。
ECMAScript の多くの実装は、Web ページを操作する追加の関数およびメソッドを提供していますが、これらの関数はこの標準の範囲外です。
この関数は、encodeURI 関数によって導入される可能性がある種類の各エスケープシーケンスおよび UTF-8 エンコーディングを、それが表すコードポイントの UTF-16 エンコーディングで置き換えた URI の新しい版を計算します。encodeURI によって導入され得ないエスケープシーケンスは置き換えられません。
これは %decodeURI% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
この関数は、encodeURIComponent 関数によって導入される可能性がある種類の各エスケープシーケンスおよび UTF-8 エンコーディングを、それが表すコードポイントの UTF-16 エンコーディングで置き換えた URI の新しい版を計算します。
これは %decodeURIComponent% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
この関数は、特定のコードポイントの各インスタンスを、そのコードポイントの UTF-8 エンコーディングを表す1つ、2つ、3つ、または4つのエスケープシーケンスで置き換えた、UTF-16 でエンコードされた(
これは %encodeURI% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
この関数は、特定のコードポイントの各インスタンスを、そのコードポイントの UTF-8 エンコーディングを表す1つ、2つ、3つ、または4つのエスケープシーケンスで置き換えた、UTF-16 でエンコードされた(
これは %encodeURIComponent% イントリンシックオブジェクトです。
呼び出されたとき、次の手順を実行します。
パーセントエンコーディングは個々のオクテットを表すために使用されるので、1つのコードポイントが複数の連続したエスケープシーケンス(8ビット UTF-8 コード単位ごとに1つ)として表現される場合があります。
RFC 3629 は無効な UTF-8 オクテット列のデコードを禁止しています。たとえば、無効な列 0xC0 0x80 をコード単位 0x0000 にデコードしてはなりません。Decode アルゴリズムの実装は、このような無効な列に遭遇した場合に